Frama-C-discuss mailing list archives

This page gathers the archives of the old Frama-C-discuss archives, that was hosted by Inria's gforge before its demise at the end of 2020. To search for mails newer than September 2020, please visit the page of the new mailing list on Renater.

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Frama-c-discuss] Problem running frama-c in Windows

  • Subject: [Frama-c-discuss] Problem running frama-c in Windows
  • From: ricardoalmeida1985 at (Ricardo Almeida)
  • Date: Wed, 16 Jun 2010 00:13:03 +0100

Hello everyone,

I've been trying to install Frama-C in Windows Vista over the past couple of
days but with no sucess. First I tried with Cygwin but was receiving several
erros, some of which I could fix, but some I couldn't. Then I decided to try
with the installation of Microsoft Visual C, so I followed the steps in, that is, I installed all the necessary software, added
the paths to the envirnment variables, etc, but when I launched Frama-C
through the GUI mode and chose the file first.c (the one from the example
test) as a C source file, when I click New, sometimes nothing happens, other
times I will get an error dialog box saying:

Frama-C aborted because of an invalid user input.
Look at the console for additional information (if any).

However, the console says nothing. When I was having problems running
frama-c-gui from Cygwin, at this point the console would say "Frama-c images
not found, is FRAMAC_SHARE variable correctly set?". This problem
disappeared after I set the SHARE variable correctly, although it never
looked like there was any picture missing in the GUI (the label of the
second button in the toolbar, the one between Exit and Save Session, has
always been blank though).

To test a different approach, I decided to try Frama-C through the command
line. I copied first.c to the bin folder of the Frama-C installation and

E:\Program Files\Frama-C\bin>frama-c.exe first.c
[kernel] preprocessing with "C:\cygwin\bin\gcc.exe -C -E I   first.c"

but no more results are shown, nor is any file created in this directory
after this command.

I also tried:

E:\Program Files\Frama-C\bin>frama-c.exe -jessie first.c
[kernel] preprocessing with "C:\cygwin\bin\gcc.exe -C -E I  -dD first.c"
[jessie] Starting Jessie translation
[jessie] user error: Nothing to process. There was probably an error before.
:0:[jessie] failure: Unexpected exception.
                  Please submit bug report (Ref.
[kernel] The full backtrace is:
         Raised at file "src/kernel/", line 506, characters 30-31
         Called from file "src/kernel/", line 500, characters 2-9
         Re-raised at file "src/kernel/", line 503, characters 8-9
         Called from file "src/lib/", line 746, characters 40-45
         Called from file "", line 134, characters 6-20
         Called from file "src/kernel/", line 50, characters 4-20
         Called from file "src/kernel/", line 170, characters 4-8

         Plug-in jessie aborted because of an internal error.
         Please report as 'crash' at

This is what I can provide at the moment. Any help is appreciated. Thanks in

Ricardo Almeida
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>