Frama-C-discuss mailing list archives

This page gathers the archives of the old Frama-C-discuss archives, that was hosted by Inria's gforge before its demise at the end of 2020. To search for mails newer than September 2020, please visit the page of the new mailing list on Renater.

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Frama-c-discuss] installing Jessie plug-in

  • Subject: [Frama-c-discuss] installing Jessie plug-in
  • From: siegel at (Stephen Siegel)
  • Date: Sun, 7 Apr 2013 21:17:48 -0600

I've run into some problems installing the Jessie plugin on OS X 10.8.3, with Frama-C Oxygen.

I downloaded why-2.32 from
Did ./configure
The Makefile turned out to have a bug here:

jc/ jc/ jc/ jc/jc_stdlib_ge40.\
        rm -f $@
        case $(OCAMLVERSION) in \                                               
         3.0*|3.10*|3.11*) cp jc/ $@ ;; \                     
         3.12*) cp jc/ $@ ;; \                                
#        4.*) cp jc/ $@ ;; \                                  
         4.0*) cp jc/ $@ ;; \                                  
        chmod -w $@


The '#' sign comments out not just the physical line but the remainder of the entire logical line (including the 'esac').
I tried deleting that physical line, then "sudo make" and "sudo make install" seemed to work without any warnings or errors.  The plugin was copied to the correct place in Frama-C.  But when I run frama-c -jessie I get this:

basic$ frama-c -jessie allZeroes.c 
[kernel] warning: cannot load plug-in `Jessie' (incompatible with Oxygen-20120901).
[kernel] user error: option `-jessie' is unknown.
                     use `frama-c -help' for more information.
[kernel] Frama-C aborted: invalid user input.