Frama-C-discuss mailing list archives

This page gathers the archives of the old Frama-C-discuss archives, that was hosted by Inria's gforge before its demise at the end of 2020. To search for mails newer than September 2020, please visit the page of the new mailing list on Renater.

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Frama-c-discuss] installing Frama-C on OS X

  • Subject: [Frama-c-discuss] installing Frama-C on OS X
  • From: siegel at (Stephen Siegel)
  • Date: Thu, 22 Aug 2013 19:34:05 -0400

I ran into an error trying to install the latest release on OS X.
I get the same error building manually or using OPAM.
I'm not sure if it's something to do with my environment, so I thought I'd ask if anyone else has encountered this.
(BTW, everything worked out fine in Ubuntu: Frama-C+Why2+Why3+Jessie -- thanks everyone)


compilation error:

share/Makefile.dynamic:196: share/Makefile.kernel: No such file or directory
Makefile:2328: .depend: No such file or directory
1 shift/reduce conflict.
67 shift/reduce conflicts.
File "src/misc/", line 248, characters 43-44:
Error: Signature mismatch:
       The field `in_degree' is required but not provided
make: *** [src/misc/service_graph.cmo] Error 2

'opam install frama-c' failed.