Frama-C-discuss mailing list archives

This page gathers the archives of the old Frama-C-discuss archives, that was hosted by Inria's gforge before its demise at the end of 2020. To search for mails newer than September 2020, please visit the page of the new mailing list on Renater.

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Frama-c-discuss] Installation problem with Neon release

  • Subject: [Frama-c-discuss] Installation problem with Neon release
  • From: rovedy at (rovedy at
  • Date: Mon, 17 Nov 2014 15:03:15 -0200


We had a Frama-C Fluorine (20130601) release, Why3 Verification Platform
0.81 in a OS X Mountain Lion Version 10.8.2.

In order to install the Neon release, we updated to:
- OS X Yosemite Version 10.10
- XCode 6.1
- opam 1.2.0
- ocaml 4.02.1

After uninstalling the Fluorine release and updating and upgrading the
OPAM, we executed the command "opam install frama-c", but an error 
occorred and the corresponding message is listed below.

We tried to solve the problem following the lablgtk.2.18.3
troubleshooting (we installed the gtk+ 2.0 with "brew"). 

We tried the install the lablgtk.2.18.3 with brew and opam, but without

We tried to install the frama-c again, but the same error remains. How
to solve this problem?

Best regards,
Rovedy, Nanci 

### stderr ###
# + gcc -fno-defer-pop -Wall -D_FILE_OFFSET_BITS=64 -D_REENTRANT -c

-D_REENTRANT -I/opt/X11/include -I/opt/X11/include/cairo
-I/opt/X11/include/pixman-1 -I/opt/X11/include/libpng15

-I/opt/X11/include/freetype2 -I/opt/X11/include
-I/opt/local/include/libglade-2.0 -I/opt/local/include/librsvg-2.0 

# clang: error: unknown argument: '-fno-defer-pop'
# make[1]: *** [ml_gdkpixbuf.o] Error 2
# make: *** [world] Error 2

=-=- Error report
The following failed
 - install lablgtk.2.18.3
Due to the errors, the following have been cancelled
 - install ocamlgraph.1.8.5
 - install frama-c.20140301

=-=- lablgtk.2.18.3 troubleshooting
=> This package requires gtk+ 2.0 development packages installed on your
=> To solve pkg-config issues, you may need to do
 'export PKG_CONFIG_PATH=/opt/X11/lib/pkgconfig' (macports)
 or 'export PKG_CONFIG_PATH=/usr/local/lib/pkgconfig' (homebrew)
 and retry

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>